2018/09/29(土)Strawberry PerlでImage::Magick(PerlMagick)ごとEXE化

Image::Magickモジュールを含むWindows用EXEが生成できる pp 環境の構築。

Strawberry Perl

Strawberry Perlのサイトから、ダウンロードしました。執筆時点で最新は「5.28.0.1」ですが、Image::Magickが入らないので、5.26.2.1を選択。

形式はどれでも構わないと思いますが、個人的にPortableを選びました。

Image::MagickとPAR::Packerの導入

Image::Magickはppmから入れるので簡単でした。

c:\> ppm
ppm> install Image::Magick
Install package 'Image-Magick?' (y/N): y

ppm> quit

続いてPAR::Packerです。PARは普通にインストールするとよくエラーが出るので、force installしました。

c:\> cpan
cpan> force install PAR::Packer

コンパイル&テストが長いのでそこそこ待たされます。

PAR::Packer Ver1.047の修正

Image::Magickをパッケージに含めるためには、Image::MagickのDLLを一緒に含める必要があります。

pp は -l オプションや -a オプションを使うと、DLLや他のファイルを一緒にパッケージ化することができます。できますが、それではImage::Magickのロードに失敗します。Image::MagickのDLLは通常と違う場所に置かれているのでDLLがロードできませんし、DLL以外の必要ファイルを参照するための情報も不足します。

これを修正するために、perl/vendor/lib/PAR.pm にパッチを充ててください。

sub import {
    my $class = shift;

    PAR::SetupProgname::set_progname();
    PAR::SetupTemp::set_par_temp_env();

    # patch for sitelib by nabe@abk ---------
    if ($ENV{PAR_TEMP} && $^O eq 'MSWin32') {
        my %conf;
        foreach(keys(%Config)) {
            $conf{$_} = $Config{$_};
        }
        *Config::Config = \%conf;   # replace read-only object

        my $base = "$ENV{PAR_TEMP}\\inc";
        $Config::Config{sitelib}    = "$base\\site\\lib";
        $Config::Config{sitelibexp} = "$base\\site\\lib";
    }
    # patch end -----------------------------

Image::Magickは環境変数を参照しながら、.dllや.xmlファイルをその都度ロードするようになっているのですが、それらのファイルは指定しないとパッケージ化されませんし、パッケージ化しても $Config{sitelib} が適切に設定されていないため、Magick.pm で正しく環境変数を設定できません。

これを解決するためのパッチになります。

Image::MagickのライブラリごとEXE化

pp コマンドの -a オプションで、Image::Magickのライブラリ類(*.dll, *.xml)を一緒にパッケージ化します。

Strawberry Perlインストールディレクトの「perl\site\lib\Image」以下にあるすべてのファイルをパッケージに収録します。面倒なのでファイルに記述してそれをコマンドラインで与えることにします。

以下は例になります。パスは適当に読み替えてください。

pp -a "C:/strawberry-perl-5.26.2.1/perl/site/lib/Image;site/lib/Image"
   -o test.exe test.pl

オプションが長くなり入力が面倒なので、pp-option というファイルを用意してその中にオプションを書きました。

pp @pp-option

注意

スクリプト内で、スレッド生成やforkをしている場合は、必ず「use Image::Magick」してください。生成されたスレッドやプロセスから「require Image::Magick」しても必要な環境変数が設定されず、Image::Magickが動作しません。

まとめ

Image::Magickモジュールごと、PerlスクリプトをEXE化できるようになりました。

ActivePerlでも同じ方法で解決できると思います。

2015/11/09(月)IPカメラ(Webcam)リレープログラム / ip-camera-relay.pl

IP Cameraの映像を中継するプログラムです。以下の機能があります。

  • IPカメラへの自動再接続。
  • 複数のIPカメラを登録し、接続できたカメラの映像を中継する。接続が切れたら、次に接続できたカメラに接続する。
  • IPカメラに接続できていない時は、指定した画像(ブランクイメージ)を代わりに送信する。

VLCなどのIPCamストリーム受信ソフトでは、カメラとの接続が切れた場合に自動再接続を行ってくれないものがあります。またカメラと接続が切れたときにブランク画像を挿入したいこともあり、それを実現するためのソフトになります。

プログラム

Gistに置いたので、適当に拾ってください。

  • ip-camera-relay.pl Perl用プログラム
  • ライセンス : GPLv2 or later
  • http転送。パスワードなし。Motion JPEG(以下MJPEG)のみ対応。

使い方

$ ip-camera-relay.pl -p 8888 http://(camera-ip):port/stream-path

クライアント接続用に8888番ポートを開き、指定したカメラに接続します。カメラURLはブラウザから接続するURLではなく、ビデオストリームのURLを指定してください*1

複数のカメラを指定すると、それぞれを順番に接続します。最初に接続できたストリームをクライアントに配信し、カメラとの接続が切れたら次に接続できたカメラの映像を送ります。

どのカメラとも接続できない時は、ブランク画像(標準では640x480の青い画像)を送信します。

その他オプションはヘルプを参照してください。

*1 : ブラウザから接続したりカメラの仕様書を見れば、書かれているかと思います。

WebCamのプロトコル

続きを読む

2015/11/06(金)UPnP/SSDPマルチキャスト中継プログラム(DLNA用)

UPnPのマルチキャストパケットを中継するためのプログラムです。通常、同一ネットワーク内でしか使用できないUPnPを、ルーターを超えて使用できるようになります。

想定

  • DLNAサーバとクライアント(またはコントローラーとレンダー)がルーターを超えて存在する。
  • それぞれネットワークAとBとすれば、A内のPCとB内のPCは互いに通信可能である(NATされていない)。
  • どちらのネットワークにも属するPCが存在する。

「WiFiと有線LAN環境を同一ネットワークにしたくない」ただそれだけなのですが、そのせいでUPnP/DLNAが超えられず大変苦労しました……。

続きを読む

ActivePerl 5.10でPARをインストール(Perlのexe化)

はてブ数 2009/08/24 プログラム::Perl

ActivePerl5.8では無理やりithread対応のPARをインストールしたり色々苦労がありましたが、ActivePerl5.10ならば比較的すんなり行きそうなので環境を構築してみました。

インストール

ActivePerl5.10をオフィシャルから落としてインストール。インストール先はc:\usrにしました*1。インストール時にPPMを入れ忘れないようにしてください。

Windowsのシステム環境変数PATHに次を追加します。後者がppのパスになります。

;c:\usr\bin;c:\usr\site\bin

PPMでPARとPAR-Packer(ppコマンド)を導入します。

>ppm install PAR
>ppm install http://www.bribes.org/perl/ppm/PAR-Packer.ppd

これでppコマンドが使えるようになります。

*1 : こうすると、c:\usr\bin\perl でperlが実行できる。

動作テスト

試しに、mixi_exportをexe化してみます。

>pp -o mixi_export.exe mixi_export.pl

無事うまく変換できました。

ひそかな人気アプリwmrelayも、Perl5.8時代は標準状態のPARで変換するとWin32ライブラリを読み込まずいろいろ大変だったのですが、Perl5.10では(必要なライブラリインストール後)あっさり変換できました。

5.16の場合

>ppm install PAR::Packer

\usr\lib\Config.pm の60行目付近を修正します。

- $^V eq 5.16.3
+ $^V eq 5.16.3 or $^V eq 5.16.0
OK キャンセル 確認 その他